linuxcnc (1:2.5.2) lucid; urgency=low

  * AXIS: Allow the setting of the top end of the Max Velocity slider
    according to [DISPLAY]MAX_LINEAR_VELOCITY as the docs say
  * Components: Fix mux16's debounce function
  * Components: LCD character display driver
  * Components: New multiclick component detects single, double, triple clicks
  * Docs: Many improvements
  * Gremlin: Better error reporting for gcode errors
  * Gremlin: Fix rotated axes display
  * Halui: Include tool length offsets in relative position outputs
  * Hostmot2: Fixes to sserial
  * Kins: Fix teleop jogging of ABC axes in the negative direction
  * Modbus: Fix TCP communication time out error
  * New config: Gecko G540
  * New config: Smithy 1240combined_mm
  * PID: Optional new error-previous-target mode to reduce ferrors detected
    by motion.  This is especially useful for torque-mode loops and those
    tunings that use large I gains
  * pncconf: Many fixes
  * PPMC: Better error checking for hardware problems causing miscommunication
  * Tool Table: Many fixes to tool table handling, making tool tables on
    nonrandom setups using mismatched tool and pocket numbers work correctly
  * Translations: German for tooledit
  * Translations: Many improvements to French
  * Utilities: new latencyhistogram program that shows details about latency
  * Utilities: sim_pin, a script that simulates writing to hal pins

 -- Chris Radek <chris@timeguy.com>  Sun, 03 Mar 2013 17:07:57 -0600

linuxcnc (1:2.5.1) lucid; urgency=low

  * Motion: fix incorrect spindle direction after G43 in CSS+M4 mode
  * Interpreter: allow G10 L1 to set front/back angles when not 
    also changing offsets
  * Interpreter: correctly report G96/G97 mode to the UI
  * Interpreter: explicitly set the default spindle mode at startup
  * task: fix incorrect spindle speed display when switching mode
    (Manual/MDI)
  * PPMC: fix a bug that would cause missing encoder velocity pins on
    some versions
  * Hostmot2: Fix a couple of bugs affecting sserial (crash on
    shutdown, memory leak)
  * Hostmot2: Add support for 6i25
  * AXIS: fix a surprise jog when the jog increment combobox was open
  * AXIS: show S word in active gcode pane
  * AXIS: rebranding
  * Touchy: rebranding, change program path to ~/linuxcnc/nc_files
  * Docs: improvements/clarifications to the halui.1 manpage
  * Docs: improvements/clarifications to the gladevcp docs
  * Docs: improvements/clarifications to the halcmd docs
  * Docs: improvements/clarifications to the gcode docs
  * Docs: fix misc typos, misspellings, grammar, and markup bugs
  * Docs: updates to French translations
  * GladeVCP: fix EMC_Action_Open
  * GladeVCP: new default-value example
  * tooledit: save/restore geometry, allow sorting on specific columns
  * tooledit: bugfixes and i18n
  * ngcgui: minor fixes and additions
  * pncconf: lots of bug fixes and incremental improvements
  * portability fix for Ubuntu Precise 12.04 LTS
  * portability fix for Fedora 16
  * Calibration: fix missing entries in tuning/calibration screens
  * emcrsh: fix incorrect relative position report for some offset settings
  * time.comp: fix hours wrapping at 60

 -- Chris Radek <chris@timeguy.com>  Sun, 29 Jul 2012 13:48:25 -0500

linuxcnc (1:2.5.0) lucid; urgency=low

  * AXIS: dynamic tabs can embed other applications, including virtual
    control panels
  * AXIS: make the gcode readout resizable
  * AXIS: many speedups in preview generation
  * AXIS: new OpenGL preview with antialiased fonts
  * AXIS: optional blending in the program preview can make very complex
    programs easier to see
  * AXIS: prompt when homing a joint that's already homed
  * AXIS: Selectable tool touch off to workpiece or fixture
  * AXIS: show all offsets and rotation separately in the BIG DRO
  * AXIS: show G5x and G92 offsets graphically in the preview
  * AXIS: user-configurable MDI history file
  * AXIS: A comment (AXIS,notify,message) will print "message" when the
    preview is generated, instead of just at run-time.

  * Configs: many configuration updates for Smithy machines
  * Configs: update motenc sample configs for encoder index
  * Configs: add filtering (image-to-gcode etc) to hostmot2 samples
  * Configs: univpwm sample uses new encoder velocity for pid

  * GladeVCP: a new framework for making virtual control panels with the
    Glade screen designer

  * Gremlin: AXIS's program preview is now separated out as gremlin,
    for use with GladeVCP/Touchy/etc.

  * HAL: fix rare problem with freqgen output getting stuck "on"
  * HAL: gearchange component: support up to 32 gears
  * HAL: make commanded (unaffected by spindle override) spindle speed
    available on a pin, for gear selection etc.
  * HAL: make limit3 parameters into pins
  * HAL: new axis.N.motor-offset pins can be used to detect position loss
    between homings
  * HAL: new component bldc_sine: commutation for BLDC with encoder feedback
  * HAL: new mux16 component
  * HAL: new time comp, which converts seconds to hr/min/sec
  * HAL: new watchdog component
  * HAL: remove deprecated hal_m5i20 driver
  * HAL: new component for ShuttleXpress USB jog dongle
  * HAL: support names= options for encoder_ratio, sim_encoder, at_pid, siggen
  * HAL: a new component, message, to display user messages from HAL
  * HAL: a new component, multiswitch, to toggle through bits with one button

  * Halshow: add menu with load/save/exit
  * Halshow: fix the tree to not cut off after a certain depth

  * HAL: standardize on maximum hal name length

  * HALUI: allow direct-value input to spindle and feed overrides and
    max velocity
  * HALUI: handle the situation better when many command inputs change
    simultaneously

  * Hostmot2: fix a rare problem in stepgen mode setting
  * Hostmot2: fix stepgen moving VERY slowly when it should have been
    stopped
  * Hostmot2: handle failed card registration better
  * Hostmot2: support for multiplexed encoders like on the 7i48
  * Hostmot2: support for onboard diagnostic LEDs
  * Hostmot2: support for three phase PWM
  * Hostmot2: improve watchdog reliability and defaults

  * Interpreter: fixes to always use . for a decimal, no matter the locale
  * Interpreter: fix G83 peck retract to match fanuc
  * Interpreter: fix G98/G99 to match fanuc retract planes behavior
  * Interpreter: fix "run from line" when the start line is between a
    sub definition and its call
  * Interpreter: give correct errors when rotary axes are commanded to
    move in canned cycles
  * Interpreter: improve arc endpoint radius-mismatch error checking
  * Interpreter: maintain G5x and G92 offsets separately
  * Interpreter: make current position including all offsets and in the
    current program units available in parameters 5420-5428
  * Interpreter: make EMC version available in named parameters _vminor,
    _vmajor
  * Interpreter: make G92 offset rotated coordinate systems correctly
  * Interpreter: make more errors translatable
  * Interpreter: many fixes to allow O-call of subroutines from MDI mode
  * Interpreter: many new tests in the test suite, including the ability
    to verify errors
  * Interpreter: new G10 L11 code for tool touch off to fixture instead
    of active work coordinate system
  * Interpreter: new unary function EXISTS tells whether a certain
    parameter exists
  * Interpreter: search path for subroutines: [RS274NGC]SUBROUTINE_PATH
  * Interpreter: search path for user M codes: [RS274NGC]USER_M_PATH
  * Interpreter: detect and error on malformed O-if[] statements

  * IOcontrol: make aborting tool changes work

  * Kinematics: several improvements to the general serial kinematics module

  * Motenc, VTI, Opto_ac5: PCI-related update for new kernel versions

  * Motion: allow translations of more error messages
  * Motion: fix stuttering motion in NURBS
  * Motion: support for indexing/locking rotary axes

  * ngcgui: many new features and bugfixes

  * PID: accept external command-deriv and feedback-deriv connections to
    use a high quality velocity signal when it is available

  * pncconf: many new features and bugfixes

  * PPMC: improve error messages when cards are not found

  * Probing: correctly abort motion when the probe trips during a non-probe
    MDI command

  * Rebranding: rename EMC to LinuxCNC

  * TkEMC: display and allow entry of all tool offsets
  * TkEMC: in Set Coordinates, display the correct axes
  * TkEMC: only display active axes
  * TkEMC: show coordinate system in offset widget
  * TkEMC: show work offsets for all axes

  * Touchy: add a spindle speed readout on the manual tab
  * Touchy: dynamic tabs can embed other applications, including virtual
    control panels
  * Touchy: macro capability that uses MDI O-call
  * Touchy: make single-block switch work like feed hold
  * Touchy: save maximum velocity (MV) value across runs
  * Touchy: Selectable tool touch off to workpiece or fixture
  * Touchy: show all offsets separately in the status information
  * Touchy: show the total number of lines in the loaded program
  * Touchy: show which tools are in which pockets
  * Touchy: support for metric configurations
  * Touchy: support panel indicators for status readout
  * Touchy: use appropriate jog and maxvel increments for metric and degrees
  * Touchy: turning the wheel during a continuous jog changes the current 
    jog speed

  * add a G code language spec for gedit
  * add latencyplot, a strip-chart type display of latency test results

 -- Chris Radek <chris@timeguy.com>  Fri, 30 Mar 2012 13:20:02 -0500